Investigating login issues for Lenovo Device Orchestration in NA region

Incident Report for Lenovo Device Orchestration

Resolved

The issue which was impacting user login is now resolved for Lenovo Device Orchestration.
Posted May 12, 2026 - 16:54 UTC

Investigating

We are currently investigating login issues for Lenovo Device Orchestration in NA region. We will provide an update as soon as progress is made on the investigation.
Posted May 12, 2026 - 14:06 UTC
This incident affected: NA Portal.