Cloudflare Network Issues affecting Lenovo UDS Portal

Incident Report for Lenovo Device Orchestration

Resolved

The incident has been resolved and there are not issues at this time.
Posted Aug 23, 2025 - 03:09 UTC

Monitoring

The Lenovo team is investigating a performance impact in our LDO Portal that began August 21. The impact was in the US region and appears to be connected with our service with CloudFlare. We are in touch with CloudFlare Support for an investigation in order to mitigate any ongoing impact and make sure this issue doesn't happen again. Please reach out to us if you have further questions. Thank you.

Reference for CloudFlare issue: https://blog.cloudflare.com/cloudflare-incident-on-august-21-2025/
Posted Aug 22, 2025 - 18:12 UTC
This incident affected: NA Portal.