Lenovo Device Orchestration - Investigating delay in system update scanning in EU region

Incident Report for Lenovo Device Orchestration

Resolved

The issue which was contributing to system update package delays in Lenovo Device Orchestration EU region is now resolved. New updates will show as available after scanning going forward.
Posted Aug 28, 2026 - 12:46 UTC

Investigating

We are currently investigating an issue which is causing a delay in system update scanning in Lenovo Device Orchestration EU region. During this time after scanning for new updates end users may encounter a delay before new system update packages are available for deployment. We will provide an update on this investigation as soon as progress is made.
Posted Aug 26, 2026 - 04:31 UTC
This incident affected: EU Portal.