Lenovo Device Orchestration - Investigating issues with incorrect Device status in NA Portal

Incident Report for Lenovo Device Orchestration

Resolved

This issue is now resolved. Device status in Lenovo Device Orchestration is now showing as expected.
Posted Jan 22, 2026 - 00:27 UTC

Investigating

We are currently investigating an issue which is causing device status to show incorrectly in Lenovo Device Orchestration. We will provide an update as soon as progress is made on the investigation.
Posted Jan 21, 2026 - 19:40 UTC
This incident affected: NA Portal.